Задачки

Для подготовки к экзаменам Cisco предлагаю поломать мозг и прорешать задачи уровня CCNP.


Задача 1.

Протоколы маршрутизации настроены на всех маршрутизаторах, перераспределение OSPF<->EIGRP настроено на маршрутизаторе R2 согласно топологии на рисунке:screenshot_1

Конфигурация маршрутизаторов:

R1:

Показать »

upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
ip tcp synwait-time 5
ip ssh version 1
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.252
ip ospf network point-to-point
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface GigabitEthernet1/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet2/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet3/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet5/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet6/0
no ip address
shutdown
negotiation auto
!
router ospf 1
log-adjacency-changes
network 10.10.10.1 0.0.0.0 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
gatekeeper
shutdown
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end

R2:

Показать »

upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
ip tcp synwait-time 5
ip ssh version 1
!
interface Loopback0
ip address 20.0.0.5 255.255.255.252
!
interface FastEthernet0/0
ip address 10.10.10.2 255.255.255.252
ip ospf network point-to-point
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 20.20.20.1 255.255.255.248
duplex auto
speed auto
!
interface GigabitEthernet1/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet2/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet3/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet5/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet6/0
no ip address
shutdown
negotiation auto
!
router eigrp 1
redistribute ospf 2 route-map OSPF-TO-EIGRP
network 20.20.20.1 0.0.0.0
default-metric 100000 10 255 1 1500
no auto-summary
!
router ospf 2
log-adjacency-changes
redistribute eigrp 1 route-map EIGRP-TO-OSPF
network 10.10.10.2 0.0.0.0 area 0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
access-list 70 permit 10.10.10.0 0.0.0.255
access-list 80 permit 20.20.20.0 0.0.0.255
no cdp log mismatch duplex
!
route-map OSPF-TO-EIGRP permit 10
match ip address 70
!
route-map EIGRP-TO-OSPF permit 10
match ip address 80
!
control-plane
!
gatekeeper
shutdown
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end

R3:

Показать »

upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
archive
log config
hidekeys
!
ip tcp synwait-time 5
ip ssh version 1
!
interface Loopback0
ip address 20.0.0.5 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 20.20.20.2 255.255.255.252
duplex auto
speed auto
!
interface GigabitEthernet1/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet2/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet3/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet5/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet6/0
no ip address
shutdown
negotiation auto
!
router eigrp 1
network 20.20.20.2 0.0.0.0
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane
!
gatekeeper
shutdown
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
end

Вопрос — почему с R1 не пингуется R3 и наоборот?

Задачки: 9 комментариев

  1. iluffka

    Возможно, потому, что в ospf/eigrp не анонсированы лупбэки это раз
    и в ACL на R2 для редистрибуции разрешены только служебные сети, куда лупбэки не попадают

  2. admin Автор записи

    Одно уточнение к вопросу: почему с R1 не пингуется IP-адрес 20.20.20.2 маршрутизатора R3 (т.е. IP-адрес физического интерфейса) и наоборот — с R3 не пингуется IP-адрес 10.10.10.1 маршрутизатора R1 (т.е. IP-адрес физического интерфейса)?

    Вывод с R1:

    Показать »

    R1#show ip ospf neighbor
    Neighbor ID Pri State Dead Time Address Interface
    20.0.0.5 0 FULL/ - 00:00:39 10.10.10.2 FastEthernet0/0

    R1#show ip route
    Gateway of last resort is not set
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
    C 10.10.10.0/30 is directly connected, FastEthernet0/0
    L 10.10.10.1/32 is directly connected, FastEthernet0/0

    Вывод с R2:

    Показать »

    R2#show ip ospf neighbor
    Neighbor ID Pri State Dead Time Address Interface
    10.10.10.1 0 FULL/ - 00:00:38 10.10.10.1 FastEthernet0/0

    R2#show ip eigrp neighbors
    EIGRP-IPv4 Neighbors for AS(1)
    H Address Interface Hold Uptime SRTT RTO Q Seq
    (sec) (ms) Cnt Num
    0 20.20.20.2 Fa0/1 12 00:10:41 15 100 0 6

    Вывод с R3:

    Показать »

    R3#show ip eigrp neighbors
    EIGRP-IPv4 Neighbors for AS(1)
    H Address Interface Hold Uptime SRTT RTO Q Seq
    (sec) (ms) Cnt Num
    0 20.20.20.1 Fa0/1 14 00:13:36 28 168 0 6

    R3#show ip route
    Gateway of last resort is not set
    20.0.0.0/8 is variably subnetted, 4 subnets, 3 masks
    C 20.0.0.0/24 is directly connected, Loopback0
    L 20.0.0.5/32 is directly connected, Loopback0
    C 20.20.20.0/30 is directly connected, FastEthernet0/1
    L 20.20.20.2/32 is directly connected, FastEthernet0/1

  3. iluffka

    R1 не пингует R3 видимо по тому, что редистрибуция из EIGRP в OSPF не проходит, возможно, из-за отсутствия параметра subnets
    redistribute eigrp 1 route-map EIGRP-TO-OSPF subnets

    R3 пингует R1 скорее всего со своего лупбека 20.0.0.2 к которому нет маршрута, т.е. пинг доходит до R1, но вернуться не может

  4. iluffka

    Да, я чо то прогнал, какой пинг если даже маршрута нет.

    Собрал схему и как бы и так всё работает
    НУ пальцем в небо: redistribute ospf 2 route-map OSPF-TO-EIGRP external 1 (2)

    1. admin Автор записи

      Сохраните конфиги маршрутизаторов и перегрузите их. Если конфиги отсюда перенесли правильно на схему, то получите вышеописанный «трабл»

  5. iluffka

    ЁПТИТЬ!

    На R3: eigrp router-id 20.0.0.20
    clear ip eigrp 1 neighbors
    Типа R3 игнорирует маршруты от другого роутера с таким же router-id как и у него самого

    Отличная задача.
    Огромное спасибо.

    Надеюсь напишете ещё :)

    1. iluffka

      R3#show ip eigrp 1 events
      Event information for AS 1:
      1 15:17:40.562 Ignored route, metric: 10.10.10.0/30 metric(284160)
      2 15:17:40.562 Ignored route, neighbor info: 20.20.20.1 Ethernet0/1
      3 15:17:40.562 Ignored route, dup routerid ext: 20.0.0.5
      4 15:17:40.562 Ignored route, dup routerid int: 20.0.0.5

  6. admin Автор записи

    Да, всё правильно) R3 игнорирует ВНЕШНИЕ (перераспределённые) маршруты от другого роутера с таким же EIGRP router-id как и у него самого

Добавить комментарий